KUALA LUMPUR, 29 DIS : Bermula 1 Januari ini, sebahagian besar daripada anda mungkin mengalami masalah menggunakan aplikasi popular WhatsApp melalui telefon pintar anda.

Menurut laporan The Independent, jutaan telefon iPhone dan Android versi lama dijangka tidak lagi menyokong kemas kini terbaharu aplikasi itu dan sekali gus bakal memaksa pemilik gajet sama ada mengemas kini peranti mereka atau membeli telefon baharu.

Portal itu berkata, iPhone yang tidak menggunakan iOS 9 ke atas atau mana-mana telefon pintar yang tidak menggunakan sekurang-kurangnya Android 4.0.3 – juga dikenali sebagai Ice Cream Sandwich, tidak lagi boleh menggunakan aplikasi milik Facebook itu.

“Ini bermaksud model iPhone 4 ke bawah, tidak lagi boleh menggunakan WhatsApp kerana telefon jenis ini tidak mampu menyokong sistem operasi IOS9.

“iPhone 4S, iPhone 5, iPhone 5S, iPhone 6, dan iPhone 6s kesemuanya dikeluarkan sebelum iOS9, tetapi masih boleh menyokong sistem operasi itu,” menurut laporan itu lagi.

Bagi telefon Android pula, antara jenis yang bakal kehilangan WhatsApp ialah Samsung Galaxy S2, HTC Desire, dan LG Optimus Black.

Bagaimanapun, laporan itu menyebut, sekitar dua bilion pengguna WhatsApp di seluruh dunia tidak akan terjejas dengan kemas kini tersebut, tetapi hanya sebilangan kecil yang menjangkau jutaan orang akan mengalami masalah berkenaan.

Jenis Telefon Pintar yang terjejas

  • Apple iPhone 1-4
  • Samsung Galaxy S2
  • HTC Desire
  • LG Optimus Black
  • Motorola Droid Razr
  • Telefon Android dikeluarkan sebelum 2010

Telefon Pintar yang perlu mengemas kini sekurang-kurangnya iOS9 atau Android OS 4.0.3

  • Apple iPhone 4S
  • iPhone 5
  • iPhone 5S
  • iPhone 6
  • iPhone 6S
  • Samsung Galaxy S3 ke atas
  • Samsung Galaxy Note
  • HTC Sensation
  • HTC Thunderbolt
  • LG Lucid
  • Motorola Droid 4
  • Sony Xperia Pro dan ke atas